+7(960) 250-82-68 sergey@mirossa.ru


button
button
button
button
button


 
Статьи
 
CSPSetup CSPSetup 4.0
rtDrivers RuToken Driver

http://www.nalog33.ru/rss/perenos_rutoken.html

На клиенте

Втыкаем Токен _клиент


На клиенте

Настройка считывателя _клиент


На клиенте

Экспорт личного сертификата _клиент


На клиенте

Проброс токена _клиент


На сервере

Настройка считывателя _сервер


На сервере

Установка личного сертификата _сервер


Процедура ПослеПодписи(ПодписанныеДанные, ДопПар) Экспорт

ПодписанныеДанные.Записать("D:\1C TEMP\ps\testSign.txt");

КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)

МенеджерКриптографии = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider","",75);

//HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Defaults\Provider

//МенеджерКриптографии = Новый МенеджерКриптографии("Aktiv ruToken CSP v1.0","",1);

Данные = новый ДвоичныеДанные("D:\1C TEMP\ps\test.txt");


опов = новый ОписаниеОповещения("ПослеПодписи", ЭтаФорма);
МенеджерКриптографии.ПарольДоступаКЗакрытомуКлючу = "12345678";
МенеджерКриптографии.НачатьПодписывание(опов, Данные);


КонецПроцедуры

Процедура ОсновныеДействияФормыПроверитьПодпись(Кнопка)

МенеджерКриптографии = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider","",75);
МенеджерКриптографии.ПарольДоступаКЗакрытомуКлючу = "12345678";

Исходный = новый ДвоичныеДанные("D:\1C TEMP\ps\test.txt");
Подпись = новый ДвоичныеДанные("D:\1C TEMP\ps\testSign.txt");

Серт = новый СертификатКриптографии;

МенеджерКриптографии.ПроверитьПодпись(Исходный, Подпись, Серт);

КонецПроцедуры