+7(960) 250-82-68 spam@mirossa.ru


 mirossa        1С           C         PHP       JAVA       MCU  


Статьи
 
 

Проброс ruToken на сервер через RDP

CSPSetup CSPSetup 4.0
rtDrivers RuToken Driver

На клиенте

Втыкаем Токен _клиент


На клиенте. Устанавливаем CSPSetup

Настройка считывателя _клиент


На клиенте. Устанавливаем RuToken Driver. Экспортируем личный сертификат.

Экспорт личного сертификата _клиент


На клиенте

Проброс токена _клиент


На сервере. Устанавливаем CSPSetup и RuToken Driver

Настройка считывателя _сервер


На сервере. Устанавливаем сертификат, экспортированный из панели Управления Рутокен на клиенте.

Установка личного сертификата _сервер


Процедура ПослеПодписи(ПодписанныеДанные, ДопПар) Экспорт

ПодписанныеДанные.Записать("D:\1C TEMP\ps\testSign.txt");

КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)

MK = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider","",75);

//HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Defaults\Provider

//MK = Новый МенеджерКриптографии("Aktiv ruToken CSP v1.0","",1);
//MK = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2012 Cryptographic Service Provider","",80);

Данные = новый ДвоичныеДанные("D:\1C TEMP\ps\test.txt");


опов = новый ОписаниеОповещения("ПослеПодписи", ЭтаФорма);
MK.ПарольДоступаКЗакрытомуКлючу = "12345678";
MK.НачатьПодписывание(опов, Данные);

//в процедуре НачатьПодписывание или Подписать по умолчанию используется сертификат из раздела Персональные сертификаты (если сертификат только один)

printScreen printScreen

// ХранилищеС = MK.ПолучитьХранилищеСертификатов(
      // ТипХранилищаСертификатовКриптографии.ПерсональныеСертификаты);
// ХранилищеС.НайтиПоСубъекту("Иван Иванович");
// ХранилищеС.НайтиПоСерийномуНомеру(
// ХранилищеС.НайтиПоОтпечатку(
КонецПроцедуры

Процедура ОсновныеДействияФормыПроверитьПодпись(Кнопка)

MK = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider","",75);
MK.ПарольДоступаКЗакрытомуКлючу = "12345678";

Исходный = новый ДвоичныеДанные("D:\1C TEMP\ps\test.txt");
Подпись = новый ДвоичныеДанные("D:\1C TEMP\ps\testSign.txt");

Серт = новый СертификатКриптографии;

MK.ПроверитьПодпись(Исходный, Подпись, Серт);

КонецПроцедуры

http://www.nalog33.ru/rss/perenos_rutoken.html